[Linux-parport] parport_pc disables Hercules mode of mdacon on one pentium

Sindi Keesan keesan at iamjlamb.com
Thu Jul 22 20:39:30 EDT 2004

On Thu, 22 Jul 2004, Adam Baker wrote:

> On Thursday 22 July 2004 02:48, Sindi Keesan wrote:
> >
> > I was able to get the third computer to work by NOT insmod'ing the
> > parport_pc module.  Load all the modules manually and mdacon works
> > properly with parport_pc, but then I load parport_pc and the Hercules mode
I meant here 'without' not 'with'
> > goes bad again.  It does not help to load mdacon before rather than after
> > parport_pc, or to rmmod parport_pc after the problem occurs.
> >
> > The fix is either not to use mdacon at all, or to insmod parport_pc
> > manually only when needed for printing, after first switching to a VGA
> > terminal.  Then I need to reboot (into DOS and then again into linux) to
> > use both monitors.  I don't often print in linux.
> >
> > Slackware 7.1, 2.2.16 kernel (specially compiled with minimal drivers for
> > Basiclinux 2).  I have not tried a different Hercules card in there, or a
> > different kernel (bare.i, for instance, which I think has parport_pc built
> > in).
> >
> > My theory is that mdacon and parport_pc are using  the same RAM on that
> > computer, if that is possible.  Another computer will not work at all with
> > Hercules cards due to RAM conflicts of some sort, I think.
> >
> > Is there some way to specify where in RAM to load a module?
> > Would it help anyone if I were to try a different Hercules card or a
> > different kernel and report back?

> My theory would be that it is the probing for possible parallel ports that is 
> causing the problem, I assume the hercules cards are old ISA cards and hence 
> may well have a register that is at a location typically used by one of the 3 

I should perhaps have informed those not familiar with these cards that
Hercules cards INCLUDE a parallel port set to IRQ 7. It takes over as LPT1
unless you can find some way to disable it (and usually there are no
jumpers or they are unlabelled).  The onboard parallel port then becomes
LPT2.  They seem to share an IRQ okay.  I have done plip with this HCG
parport (but don't know how to do it with LPT2).  On one HGC card plip did
not work though laplink pro worked.  On another card the parport was dead.

> standard parallel ports. My first suggestion is therefore to specify when 
> insmod'ing parport_pc the io address to use which should prevent other 
> addresses from being probed. It is also worth seeing if the problem follows 
> the card if you move it between machines.

I will attempt to do this.  Presumably the io address is the same as the
BIOS default for the onboard LPT1 (378).  
insmod parport_pc io=0x378 irq=7   
(My guess is based on a beginner's experience with ISA ethernet cards).

I can also try a different card in that motherboard and a different 
motherboard with that card.  

Thanks for the prompt helpful suggestion.

> _______________________________________________
> Linux-parport mailing list
> Linux-parport at lists.infradead.org
> http://lists.infradead.org/mailman/listinfo/linux-parport

More information about the Linux-parport mailing list