[Linux-parport] Problem with Zip 250

David Renström david.renstrom at skelleftea.mail.telia.com
Tue Jul 6 19:25:19 EDT 2004

Hi everyone!

I've been trying all day to get my parallel port connected Zip 250 to work 
with my Gentoo Linux distribution. As the subject implies, this hasn't 
really been a walk in the park. When I've re-compiled the kernel (2.4.25) 
with support for SCSI disks, and IMM and LP as standalone modules, I load 
the IMM module and get the following messages:

imm: Version 2.05 (for Linux 2.4.0)
imm: Found device at ID 6, Attempting to use EPP 16 bit
imm: Communication established at 0x378 with ID 6 using EPP 16 bit
scsi0 : Iomega VPI2 (imm) interface
Vendor: IOMEGA``  Model: ZIP`rup`````````  Rev: Jntu
Type:   Direct-Access                      ANSI SCSI revision: 02
Attached scsi removable disk sda at scsi0, channel 0, id 6, lun 0
sda : unsupported sector size 1077953088.
SCSI device sda: 0 1077953088-byte hdwr sectors (0 MB)

So, the driver seems to think that the disk consists of a single sector of 
about 1 GB! That's ridiculuous because all my disks are only 250 MB in 
size. I then tried to access the drive from DOS (and another computer) and 
it worked perfect. I actually scandisked the same disk, but no errors were 

By the way: When I tried to load the module (IMM) when there was no disk 
inserted, the usbdevfs went nuts and printed lots of errors across the 
screen. Why?

Please help me to figure out what's going on here. Thanks in advance.

Kindest Regards,
/David R.

* Phone:        +46(0)910-78 17 51                                 *
* Mobile:       +46(0)70-641 96 20                                 *
* Mail:         david.renstrom at skelleftea.mail.telia.com *
* ICQ#: 122060651                                              *

More information about the Linux-parport mailing list