[PATCH v2 0/1] nvme-rdma: fix -EIO cleanup order in queue_rq

Xixin Liu liuxixin at kylinos.cn
Tue Aug 18 23:30:00 PDT 2026


Hi,

Thanks Christoph for the if/else readability suggestion on the
RESOURCE versus IOERR branch.

Changes since v1:
- use if/else for RESOURCE versus IOERR as suggested by Christoph
- initialize err to 0 for the shared unmap_qe path

Thanks,
Xixin Liu

---

Xixin Liu (1):
  nvme-rdma: fix -EIO cleanup order in queue_rq

 drivers/nvme/host/rdma.c | 18 ++++++++++--------
 1 file changed, 10 insertions(+), 8 deletions(-)

-- 
2.53.0




More information about the Linux-nvme mailing list