[PATCH 4/5] nvme: Add a new exported function nvme_request_shutdown().

Jeremy Allison jra at samba.org
Tue Jan 30 09:31:40 PST 2024


On Tue, Jan 30, 2024 at 12:58:31PM +0200, Sagi Grimberg wrote:
>>+	ctrl->ctrl_config &= ~NVME_CC_SHN_MASK;
>>+	ctrl->ctrl_config |= NVME_CC_SHN_NORMAL;
>>+	return ctrl->ops->reg_write32(ctrl, NVME_REG_CC, ctrl->ctrl_config);
>>+}
>>+EXPORT_SYMBOL_GPL(nvme_request_shutdown);
>
>I think the name can be better, nvme_request_shutdown makes it seem
>that you are actually sending a request to the controller.
>
>Maybe nvme_ctrl_shutdown_start ? or as I suggested before
>nvme_shutdown_nowait ?

I think the idea of adding _ctrl_ in the name is a good
one as it makes explicit the level it's operating on.

I think nvme_ctrl_shutdown_start() is the better name,
so I'll use that for the next version.

Thanks !



More information about the Linux-nvme mailing list