[PATCH] nvme: ensure disabling pairs with unquiesce

Christoph Hellwig hch at lst.de
Thu Jul 6 05:51:34 PDT 2023


> +static int nvme_disable_prepare_reset(struct nvme_dev *dev, bool shutdown);

Can we rename nvme_disable_prepare_reset while we're at it?  The
name already is a bit suboptimal in the xisting code, but with
the new calles becomes really confusing.

nvme_pci_wait_for_reset_and_disable is what I could come up with.
It feels a bit too verbose, but at least it's descriptive.

> +disable:
> +	if (!nvme_disable_prepare_reset(dev, false) &&
> +	    nvme_try_sched_reset(&dev->ctrl))

Why do we wait for a reset just to schedule another reset here?

Also I feel splitting out the changes to wait for reset from those
that add the unquiesce when we can't reset into another patch
would probably help beeing able to understand the changes here.



More information about the Linux-nvme mailing list