[PATCH 3/5] nvme: refactor namespace probing

Christoph Hellwig hch at lst.de
Wed Jul 20 02:02:34 PDT 2022


On Wed, Jul 20, 2022 at 10:19:12AM +0200, Joel Granados wrote:
> > +struct nvme_ns_info {
> > +	struct nvme_ns_ids ids;
> > +	u32 nsid;
> > +	__le32 anagrpid;
> > +	bool is_shared;
> > +	bool is_ready;
> > +};
> Nitpick after looking at this for the second time:
> Should we use tabs instead of spaces to increase readability here?

Not sure why that would help.

> > -	unsigned lbaf = nvme_lbaf_index(id->flbas);
> > +	struct nvme_id_ns *id;
> > +	unsigned lbaf;
> Checkpatch.pl has a warning here for use of 'unsigned int' instead of
> just 'unsigned'

checkpatch is, as so often, rather misguided here.



More information about the Linux-nvme mailing list