[PATCH] nvme-pci: Avoid use of goto in nvme_reset_work()

Keith Busch keith.busch at intel.com
Thu May 10 10:00:39 PDT 2018


On Thu, May 10, 2018 at 11:46:33AM -0500, Alexandru Gagniuc wrote:
> This patch started as a challenge from Keith relating to code
> structuring with goto vs return. I think the final result improves
> readability on two counts:
> First, it clarifies the separation between work struct and nvme_dev.
> Second, it makes it clearer what error is being passed on:
> 'return -ENODEV' vs 'goto out', where 'result' happens to be -ENODEV
> 
> CC: Keith Busch <keith.busch at intel.com>
> Signed-off-by: Alexandru Gagniuc <mr.nuke.me at gmail.com>

Ah, that's just wrapping a function that has a single out. The challenge
is to find a better mechanism than 'goto' to unwind a failure that has
multiple outs, like nvme_probe().



More information about the Linux-nvme mailing list