[PATCH 6/6] nvme/rdma: Make nvme_rdma_conn_rejected() more informative

Steve Wise swise at opengridcomputing.com
Thu Oct 20 11:11:17 PDT 2016

> On 10/20/2016 10:45 AM, Steve Wise wrote:
> > I agree.  What if we add a helper function in the core to map the
>  > event->status value to something human readable?  That would at
>  > least push this into the core.   The nvme host really doesn't do
>  > anything other than display a different message...
> >
> > Something like rdma_event_msg(), but using event->status.
> Hello Steve,
> It won't be possible to let rdma_event_msg() decode the NVME_RDMA_CM_*
> status unless a callback function that performs such decoding is passed
> to rdma_event_msg(). Since such an approach would work for translating a
> status into a message but not for any more advanced CM status handling
> my preference is to unify the calling conventions for IB/RoCE and iWARP
> CM reject callbacks.

I think for this particular case, mapping event->status to a string is all that nvme needs.  And having a status to string mapping would be easy to do in the core.  I agree though, that unifying the status codes is a "good thing".  

More information about the Linux-nvme mailing list