[PATCH 4/4] mtd: st_spi_fsm: Simplify error checking in .probe() a bit

Uwe Kleine-König u.kleine-koenig at pengutronix.de
Tue Jun 7 08:24:58 PDT 2022


Instead of ending each if branch with the same check, do it once
unconditionally after the if block.

Signed-off-by: Uwe Kleine-König <u.kleine-koenig at pengutronix.de>
---
Not entirely sure this is an objective improvement, but I like it better
this way.

It could be shorted one step further by doing

	ret = (info->config ?: stfsm_prepare_rwe_seqs_default)(fsm);
	if (ret)
		goto err_clk_unprepare;

but IMHO readability suffers here.

 drivers/mtd/devices/st_spi_fsm.c | 11 ++++-------
 1 file changed, 4 insertions(+), 7 deletions(-)

diff --git a/drivers/mtd/devices/st_spi_fsm.c b/drivers/mtd/devices/st_spi_fsm.c
index 9f6d4dd8bade..54861d889c30 100644
--- a/drivers/mtd/devices/st_spi_fsm.c
+++ b/drivers/mtd/devices/st_spi_fsm.c
@@ -2084,15 +2084,12 @@ static int stfsm_probe(struct platform_device *pdev)
 	 * Configure READ/WRITE/ERASE sequences according to platform and
 	 * device flags.
 	 */
-	if (info->config) {
+	if (info->config)
 		ret = info->config(fsm);
-		if (ret)
-			goto err_clk_unprepare;
-	} else {
+	else
 		ret = stfsm_prepare_rwe_seqs_default(fsm);
-		if (ret)
-			goto err_clk_unprepare;
-	}
+	if (ret)
+		goto err_clk_unprepare;
 
 	fsm->mtd.name		= info->name;
 	fsm->mtd.dev.parent	= &pdev->dev;
-- 
2.36.1




More information about the linux-mtd mailing list