[PATCH 24/29] block: add a sb_bdev_nr_blocks helper
Kees Cook
keescook at chromium.org
Tue Oct 12 23:27:42 PDT 2021
On Wed, Oct 13, 2021 at 07:10:37AM +0200, Christoph Hellwig wrote:
> Add a helper to return the size of sb->s_bdev in sb->s_blocksize_bits
> based unites. Note that SECTOR_SHIFT has to be open coded due to
> include dependency issues for now, but I have a plan to sort that out
> eventually.
Wouldn't that just need a quick lift into a new header file to be
included by genhd.h, blkev.h, and:
drivers/mtd/ssfdc.c:#define SECTOR_SHIFT 9
fs/hfsplus/hfsplus_raw.h:#define HFSPLUS_SECTOR_SHIFT 9
I think that's worth doing at some point in this series since genhd.h
already has existing open-coded "9"s. And, really, a *lot* of other
places too:
$ git grep -E '(<<|>>) 9' | grep -E '\b(block|blk|sector|bdev)\b' | wc -l
240
>
> Signed-off-by: Christoph Hellwig <hch at lst.de>
> ---
> include/linux/genhd.h | 6 ++++++
> 1 file changed, 6 insertions(+)
>
> diff --git a/include/linux/genhd.h b/include/linux/genhd.h
> index 082a3e5fd8fa1..6eaef8fa78bcd 100644
> --- a/include/linux/genhd.h
> +++ b/include/linux/genhd.h
> @@ -245,6 +245,12 @@ static inline sector_t get_capacity(struct gendisk *disk)
> return bdev_nr_sectors(disk->part0);
> }
>
> +static inline u64 sb_bdev_nr_blocks(struct super_block *sb)
> +{
> + return bdev_nr_sectors(sb->s_bdev) >>
> + (sb->s_blocksize_bits - 9 /* SECTOR_SHIFT */);
> +}
> +
> int bdev_disk_changed(struct gendisk *disk, bool invalidate);
> void blk_drop_partitions(struct gendisk *disk);
>
> --
> 2.30.2
>
--
Kees Cook
More information about the linux-mtd
mailing list