[PATCH 1/1] mtd: mtdpart: use DEVICE_ATTR_RO() helper macro
Zhen Lei
thunder.leizhen at huawei.com
Thu Jun 3 05:30:41 PDT 2021
Use DEVICE_ATTR_RO() helper macro instead of plain DEVICE_ATTR(), which
makes the code a bit shorter and easier to read.
Signed-off-by: Zhen Lei <thunder.leizhen at huawei.com>
---
drivers/mtd/mtdpart.c | 7 +++----
1 file changed, 3 insertions(+), 4 deletions(-)
diff --git a/drivers/mtd/mtdpart.c b/drivers/mtd/mtdpart.c
index 66a67c6e3cbc049..04af12b66110c60 100644
--- a/drivers/mtd/mtdpart.c
+++ b/drivers/mtd/mtdpart.c
@@ -212,15 +212,14 @@ static struct mtd_info *allocate_partition(struct mtd_info *parent,
return child;
}
-static ssize_t mtd_partition_offset_show(struct device *dev,
- struct device_attribute *attr, char *buf)
+static ssize_t offset_show(struct device *dev,
+ struct device_attribute *attr, char *buf)
{
struct mtd_info *mtd = dev_get_drvdata(dev);
return sysfs_emit(buf, "%lld\n", mtd->part.offset);
}
-
-static DEVICE_ATTR(offset, S_IRUGO, mtd_partition_offset_show, NULL);
+static DEVICE_ATTR_RO(offset); /* mtd partition offset */
static const struct attribute *mtd_partition_attrs[] = {
&dev_attr_offset.attr,
--
2.26.0.106.g9fadedd
More information about the linux-mtd
mailing list