[PATCH v4 1/2] mtd: spinand: micron: Generalize the function and structure names

Miquel Raynal miquel.raynal at bootlin.com
Mon Sep 28 10:55:28 EDT 2020


Hi Thirumalesha,

Thirumalesha N <nthirumalesha7 at gmail.com> wrote on Sun, 20 Sep 2020
22:38:53 +0800:

> Hi Miquèl,
> 
> I adopted these changes as per the Boris Brezillon comments
> 
> On Tue, Sep 15, 2020 at 4:13 PM Miquel Raynal <miquel.raynal at bootlin.com>
> wrote:
> 
> > Hi Thirumalesha,
> >
> > Thirumalesha Narasimhappa <nthirumalesha7 at gmail.com> wrote on Mon, 14
> > Sep 2020 00:15:32 +0800:
> >  
> > > Rename the oob structure and read/write/update function names to
> > > a generic names
> > >
> > > Signed-off-by: Thirumalesha Narasimhappa <nthirumalesha7 at gmail.com>
> > > ---
> > >  drivers/mtd/nand/spi/micron.c | 80 +++++++++++++++++------------------
> > >  1 file changed, 40 insertions(+), 40 deletions(-)
> > >
> > > diff --git a/drivers/mtd/nand/spi/micron.c  
> > b/drivers/mtd/nand/spi/micron.c  
> > > index 5d370cfcdaaa..d1b1073d1a55 100644
> > > --- a/drivers/mtd/nand/spi/micron.c
> > > +++ b/drivers/mtd/nand/spi/micron.c
> > > @@ -28,7 +28,7 @@
> > >
> > >  #define MICRON_SELECT_DIE(x) ((x) << 6)
> > >
> > > -static SPINAND_OP_VARIANTS(read_cache_variants,
> > > +static SPINAND_OP_VARIANTS(quadio_read_cache_variants,
> > >               SPINAND_PAGE_READ_FROM_CACHE_QUADIO_OP(0, 2, NULL, 0),
> > >               SPINAND_PAGE_READ_FROM_CACHE_X4_OP(0, 1, NULL, 0),
> > >               SPINAND_PAGE_READ_FROM_CACHE_DUALIO_OP(0, 1, NULL, 0),
> > > @@ -36,11 +36,11 @@ static SPINAND_OP_VARIANTS(read_cache_variants,
> > >               SPINAND_PAGE_READ_FROM_CACHE_OP(true, 0, 1, NULL, 0),
> > >               SPINAND_PAGE_READ_FROM_CACHE_OP(false, 0, 1, NULL, 0));
> > >
> > > -static SPINAND_OP_VARIANTS(write_cache_variants,
> > > +static SPINAND_OP_VARIANTS(x4_write_cache_variants,  
> >
> > Why quadio_read and x4_write? I don't get the logic.
> >  
> 
> IMHO, quadio_read is derived from SPINAND_PAGE_READ_FROM_CACHE_QUADIO_OP &
> x4_write is derived from SPINAND_PROG_LOAD_X4
> 
> Boris, Please correct me, if my understanding is wrong

I see.

Then please split this change, one updating the helpers with an "x4"
prefix when relevant and another one for 8 vs. grouped.

> 
> 
> > >               SPINAND_PROG_LOAD_X4(true, 0, NULL, 0),
> > >               SPINAND_PROG_LOAD(true, 0, NULL, 0));
> > >
> > > -static SPINAND_OP_VARIANTS(update_cache_variants,
> > > +static SPINAND_OP_VARIANTS(x4_update_cache_variants,
> > >               SPINAND_PROG_LOAD_X4(false, 0, NULL, 0),
> > >               SPINAND_PROG_LOAD(false, 0, NULL, 0));
> > >
> > > @@ -69,7 +69,7 @@ static int micron_8_ooblayout_free(struct mtd_info  
> > *mtd, int section,  
> > >       return 0;
> > >  }
> > >
> > > -static const struct mtd_ooblayout_ops micron_8_ooblayout = {
> > > +static const struct mtd_ooblayout_ops micron_grouped_ooblayout = {  
> >
> > Is this necessary? What does "grouped" means? Should we rename all
> > functions with _8_ in it to make sense?
> >  
> 
> IMHO, grouped means, ecc bytes are at continuous address, where as
> interleaved means ecc bytes splitted into multiple addresses

I don't like the name. Interleaved means that there are OOB bytes
stored in the data section, which is not the case here. The way OOB
bytes are organized do not seem relevant to me, I think i prefer the
"_4_/_8_" naming,even if it's not very explicit.

Also please be consistent, do not mix "_4_" and "interleaved" (see the
other patch).

Any feedback from Micron to validate these changes will be appreciated.

Thanks,
Miquèl



More information about the linux-mtd mailing list