[PATCH 1/2] mtd: onenand: Use a better name for samsung driver

Miquel Raynal miquel.raynal at bootlin.com
Tue Jan 14 09:04:08 PST 2020


On Mon, 2019-12-30 at 17:31:02 UTC, Miquel Raynal wrote:
> Commit 55ed51fff224 ("{tty: serial, nand: onenand}: samsung: rename to
> fix build warning") has changed the samsung.c driver to be
> samsung_mtd.c in order to avoid a conflict in module names with the
> tty driver.
> 
> Since the *_mtd suffix is very undescriptive, rename it to
> onenand_samsung.c, following the folder's convention. Same will be
> applied to the omap2 onenand driver.
> 
> Signed-off-by: Miquel Raynal <miquel.raynal at bootlin.com>

Applied to https://git.kernel.org/pub/scm/linux/kernel/git/mtd/linux.git nand/next.

Miquel



More information about the linux-mtd mailing list