[PATCH] mtd: cfi_cmdset_0002: Change definition naming to retry write operation
Boris Brezillon
boris.brezillon at bootlin.com
Tue May 8 10:03:52 PDT 2018
On Tue, 8 May 2018 15:58:34 +0000
IKEGAMI Tokunori <ikegami at allied-telesis.co.jp> wrote:
> From: Tokunori Ikegami <ikegami at allied-telesis.co.jp>
>
> The definition can be used for other write operations also.
> So change the naming to MAX_WRITE_RETRIES from MAX_WORD_RETRIES.
>
> Signed-off-by: Tokunori Ikegami <ikegami at allied-telesis.co.jp>
> Cc: Chris Packham <chris.packham at alliedtelesis.co.nz>
> Cc: Brian Norris <computersforpeace at gmail.com>
> Cc: David Woodhouse <dwmw2 at infradead.org>
> Cc: Boris Brezillon <boris.brezillon at free-electrons.com>
> Cc: Marek Vasut <marek.vasut at gmail.com>
> Cc: Richard Weinberger <richard at nod.at>
> Cc: Cyrille Pitchen <cyrille.pitchen at wedev4u.fr>
> Cc: linux-mtd at lists.infradead.org
> ---
> drivers/mtd/chips/cfi_cmdset_0002.c | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/mtd/chips/cfi_cmdset_0002.c b/drivers/mtd/chips/cfi_cmdset_0002.c
> index 56aa6b75213d..28b07336bda3 100644
> --- a/drivers/mtd/chips/cfi_cmdset_0002.c
> +++ b/drivers/mtd/chips/cfi_cmdset_0002.c
> @@ -42,7 +42,7 @@
> #define AMD_BOOTLOC_BUG
> #define FORCE_WORD_WRITE 0
>
> -#define MAX_WORD_RETRIES 3
> +#define MAX_WRITE_RETRIES 3
You're about to use the same value for erase attempts, so why not
naming it MAX_RETRIES directly?
>
> #define SST49LF004B 0x0060
> #define SST49LF040B 0x0050
> @@ -1646,7 +1646,7 @@ static int __xipram do_write_oneword(struct map_info *map, struct flchip *chip,
> map_write( map, CMD(0xF0), chip->start );
> /* FIXME - should have reset delay before continuing */
>
> - if (++retry_cnt <= MAX_WORD_RETRIES)
> + if (++retry_cnt <= MAX_WRITE_RETRIES)
> goto retry;
>
> ret = -EIO;
> @@ -2105,7 +2105,7 @@ static int do_panic_write_oneword(struct map_info *map, struct flchip *chip,
> map_write(map, CMD(0xF0), chip->start);
> /* FIXME - should have reset delay before continuing */
>
> - if (++retry_cnt <= MAX_WORD_RETRIES)
> + if (++retry_cnt <= MAX_WRITE_RETRIES)
> goto retry;
>
> ret = -EIO;
More information about the linux-mtd
mailing list