[PATCH] mtd: spi-nor: hisi: Avoid generic function names

Marek Vasut marek.vasut at gmail.com
Tue Apr 10 13:58:00 PDT 2018

On 04/10/2018 10:01 PM, Ezequiel Garcia wrote:
> Using generic names such as get_if_type() is frowned
> upon: it suggests a core function (which is not),
> and then it makes code navigation harder.
> Given drivers are often used as starting point
> to write other drivers, generic names tend to spread
> like the flu. Cure the problem.
> Signed-off-by: Ezequiel Garcia <ezequiel at collabora.com>

Reviewed-by: Marek Vasut <marek.vasut at gmail.com>

Best regards,
Marek Vasut

More information about the linux-mtd mailing list