[PATCH] mtd: nand: lpc32xx_slc: Remove unneeded NULL check on 'rc'

Boris Brezillon boris.brezillon at free-electrons.com
Tue Jan 3 02:55:35 PST 2017


On Tue, 29 Nov 2016 13:28:52 -0200
Fabio Estevam <fabio.estevam at nxp.com> wrote:

> devm_ioremap_resource() does a NULL check on the 'rc' argument, so
> remove the unneeded manual NULL check.
> 
> While at it, place the 'rc' assignment just before
> devm_ioremap_resource() to improve readability.
> 

Applied.

Thanks,

Boris

> Signed-off-by: Fabio Estevam <fabio.estevam at nxp.com>
> ---
>  drivers/mtd/nand/lpc32xx_slc.c | 9 ++-------
>  1 file changed, 2 insertions(+), 7 deletions(-)
> 
> diff --git a/drivers/mtd/nand/lpc32xx_slc.c b/drivers/mtd/nand/lpc32xx_slc.c
> index 53bafe2..a0669a3 100644
> --- a/drivers/mtd/nand/lpc32xx_slc.c
> +++ b/drivers/mtd/nand/lpc32xx_slc.c
> @@ -797,22 +797,17 @@ static int lpc32xx_nand_probe(struct platform_device *pdev)
>  	struct resource *rc;
>  	int res;
>  
> -	rc = platform_get_resource(pdev, IORESOURCE_MEM, 0);
> -	if (rc == NULL) {
> -		dev_err(&pdev->dev, "No memory resource found for device\n");
> -		return -EBUSY;
> -	}
> -
>  	/* Allocate memory for the device structure (and zero it) */
>  	host = devm_kzalloc(&pdev->dev, sizeof(*host), GFP_KERNEL);
>  	if (!host)
>  		return -ENOMEM;
> -	host->io_base_dma = rc->start;
>  
> +	rc = platform_get_resource(pdev, IORESOURCE_MEM, 0);
>  	host->io_base = devm_ioremap_resource(&pdev->dev, rc);
>  	if (IS_ERR(host->io_base))
>  		return PTR_ERR(host->io_base);
>  
> +	host->io_base_dma = rc->start;
>  	if (pdev->dev.of_node)
>  		host->ncfg = lpc32xx_parse_dt(&pdev->dev);
>  	if (!host->ncfg) {




More information about the linux-mtd mailing list