[PATCH] mtd: nand: lpc32xx_slc: Remove unneeded NULL check on 'rc'
Marek Vasut
marek.vasut at gmail.com
Tue Nov 29 09:30:48 PST 2016
On 11/29/2016 04:28 PM, Fabio Estevam wrote:
> devm_ioremap_resource() does a NULL check on the 'rc' argument, so
> remove the unneeded manual NULL check.
>
> While at it, place the 'rc' assignment just before
> devm_ioremap_resource() to improve readability.
>
> Signed-off-by: Fabio Estevam <fabio.estevam at nxp.com>
> ---
> drivers/mtd/nand/lpc32xx_slc.c | 9 ++-------
> 1 file changed, 2 insertions(+), 7 deletions(-)
>
> diff --git a/drivers/mtd/nand/lpc32xx_slc.c b/drivers/mtd/nand/lpc32xx_slc.c
> index 53bafe2..a0669a3 100644
> --- a/drivers/mtd/nand/lpc32xx_slc.c
> +++ b/drivers/mtd/nand/lpc32xx_slc.c
> @@ -797,22 +797,17 @@ static int lpc32xx_nand_probe(struct platform_device *pdev)
> struct resource *rc;
> int res;
>
> - rc = platform_get_resource(pdev, IORESOURCE_MEM, 0);
> - if (rc == NULL) {
> - dev_err(&pdev->dev, "No memory resource found for device\n");
> - return -EBUSY;
> - }
I can understand the original code where you avoid calling the malloc()
in case of failure, but that looks like microoptimization to me.
Acked-by: Marek Vasut <marek.vasut at gmail.com>
> /* Allocate memory for the device structure (and zero it) */
> host = devm_kzalloc(&pdev->dev, sizeof(*host), GFP_KERNEL);
> if (!host)
> return -ENOMEM;
> - host->io_base_dma = rc->start;
>
> + rc = platform_get_resource(pdev, IORESOURCE_MEM, 0);
> host->io_base = devm_ioremap_resource(&pdev->dev, rc);
> if (IS_ERR(host->io_base))
> return PTR_ERR(host->io_base);
>
> + host->io_base_dma = rc->start;
> if (pdev->dev.of_node)
> host->ncfg = lpc32xx_parse_dt(&pdev->dev);
> if (!host->ncfg) {
>
--
Best regards,
Marek Vasut
More information about the linux-mtd
mailing list