[PATCH 02/35] block: add REQ_OP definitions and bi_op/op fields

Martin K. Petersen martin.petersen at oracle.com
Wed Jan 6 15:17:01 PST 2016


>>>>> "Mike" == mchristi  <mchristi at redhat.com> writes:

+enum req_op {
+	REQ_OP_READ,
+	REQ_OP_WRITE		= REQ_WRITE,
+	REQ_OP_DISCARD		= REQ_DISCARD,
+	REQ_OP_WRITE_SAME	= REQ_WRITE_SAME,
+};
+

I have been irked by the REQ_ prefix in bios since the flags were
consolidated a while back. When I attempted to fix the READ/WRITE mess I
used a BLK_ prefix as a result.

Anyway. Just bikeshedding...

-- 
Martin K. Petersen	Oracle Linux Engineering



More information about the linux-mtd mailing list