[PATCH v2 00/16] clk: a collection of various clean-ups and improvements
Masahiro Yamada
yamada.masahiro at socionext.com
Mon Dec 28 02:24:56 PST 2015
I sent this series to linux-mtd by mistake.
This should have been sent to linux-clk, of course.
Sorry for noise.
2015-12-28 19:10 GMT+09:00 Masahiro Yamada <yamada.masahiro at socionext.com>:
> Many refactoring, with detection of circular parent looping.
>
>
> Changes in v2:
> - Fix a bug. Return -EINVAL when parent _is_ NULL.
>
> Masahiro Yamada (16):
> clk: remove unused first argument of __clk_init()
> clk: change the argument of __clk_init() into pointer to clk_core
> clk: rename __clk_init() into __clk_core_init()
> clk: remove unnecessary !core->parents conditional
> clk: change sizeof(struct clk *) to sizeof(*core->parents)
> clk: move core->parents allocation to clk_register()
> clk: simplify clk_core_get_parent_by_index()
> clk: drop the initial core->parents look-ups from __clk_core_init()
> clk: replace pr_warn() with pr_err() for fatal cases
> clk: move checking .git_parent to __clk_core_init()
> clk: simplify __clk_init_parent()
> clk: avoid circular clock topology
> clk: walk the orphan clock list more simply
> clk: make sure parent is not NULL in clk_fetch_parent_index()
> clk: simplify clk_fetch_parent_index() function
> clk: slightly optimize clk_core_set_parent()
--
Best Regards
Masahiro Yamada
More information about the linux-mtd
mailing list