[PATCH v3 1/3] mtd: nand: add a helper to parse the Hynix nand
Brian Norris
computersforpeace at gmail.com
Fri Mar 7 02:41:34 EST 2014
On Fri, Jan 03, 2014 at 04:08:36PM +0800, Huang Shijie wrote:
> This patch adds a nand_parse_hynix() to parse the Hynix MLC nand
> whose ID length is 6 bytes.
>
> This patch makes preparations for parsing other Hynix nand.
>
> Signed-off-by: Huang Shijie <b32955 at freescale.com>
> ---
> drivers/mtd/nand/nand_base.c | 89 +++++++++++++++++++++++------------------
> 1 files changed, 50 insertions(+), 39 deletions(-)
>
> diff --git a/drivers/mtd/nand/nand_base.c b/drivers/mtd/nand/nand_base.c
> index 4ce8007..d6b7dc3 100644
> --- a/drivers/mtd/nand/nand_base.c
> +++ b/drivers/mtd/nand/nand_base.c
> @@ -3198,6 +3198,55 @@ static int nand_get_bits_per_cell(u8 cellinfo)
> return bits + 1;
> }
>
> +/* Parse for the Hynix MLC nand which has 6-bytes ID */
> +static void nand_parse_hynix(struct mtd_info *mtd, struct nand_chip *chip,
> + u8 id_data[8], int *busw)
> +{
Can you use 'decode' instead of 'parse', so the naming is like
nand_decode_id() and nand_decode_ext_id()?
Brian
More information about the linux-mtd
mailing list