[PATCH for mtd-utils 0/4] about the SLC/MLC

Brian Norris computersforpeace at gmail.com
Tue Oct 22 16:33:49 PDT 2013


On Tue, Aug 20, 2013 at 01:58:33PM +0800, Huang Shijie wrote:
> This patch set is just following the kernel changes about the SLC/MLC,
> Please see:
>   http://lists.infradead.org/pipermail/linux-mtd/2013-August/048160.html
> 
> This patch set tries to make the mtd-utils still runs in the _old_ logic
> after we changed the code in kernel.
> 
> (The maillist blocks my email for the suspicious header, so i changed the
>  title and resend it.)
> 
> 
> Huang Shijie (4):
>   add the MTD_MLCNANDFLASH case
>   mtd: mtd-abi: add a helper to detect the nand type
>   Use the mtd_type_is_nand_user() to check the nand
>   check the MLC nand type
> 
>  flash_otp_write.c     |    4 ++--
>  include/mtd/mtd-abi.h |    5 +++++
>  lib/libmtd.c          |    5 ++++-
>  lib/libmtd_legacy.c   |    3 +++
>  mtd_debug.c           |    3 +++
>  ubi-utils/mtdinfo.c   |    2 +-
>  6 files changed, 18 insertions(+), 4 deletions(-)

Pushed to mtd-utils.git. Thanks!

You're missing flash_erase.c, which still has:

	isNAND = mtd.type == MTD_NANDFLASH ? 1 : 0;

Maybe you want a helper for struct mtd_dev_info too? Or maybe just a
helper that looks at type 'int', so it applies to both mtd_dev_info.type
and mtd_info_user.type?

Brian



More information about the linux-mtd mailing list