[RFC] do_mounts: Allow mtd names for non-flash block filesystems
karl.beldan at gmail.com
Tue Oct 12 11:11:27 EDT 2010
On Tue, Oct 12, 2010 at 4:27 PM, Artem Bityutskiy <dedekind1 at gmail.com> wrote:
> On Tue, 2010-10-12 at 15:16 +0200, Karl Beldan wrote:
>> On Mon, Oct 11, 2010 at 9:24 PM, Artem Bityutskiy <dedekind1 at gmail.com> wrote:
>> > On Wed, 2010-10-06 at 23:02 +0200, Karl Beldan wrote:
>> >> Hi,
>> >> I have been using this tweak for some time now, and I am getting tired of
>> >> having to resort to it so often.
>> >> It allows to pass such cmdline root as:
>> >> "root=mtdb:ubivolx rootfstype=squashfs"
>> >> I am pretty sure many people use squashfs/cramfs filesystems on top of nand,
>> >> for example, and I thought that this might initiate discussion.
>> >> --
>> >> Karl
>> >> Signed-off-by: Karl Beldan <karl.beldan at gmail.com>
>> >> ---
>> >> init/do_mounts.c | 15 +++++++++++++--
>> >> 1 files changed, 13 insertions(+), 2 deletions(-)
>> > Dunno...
>> > First of all, if you have to do this, let it be mtdblock, not mtdb - no
>> > need to breed aliases.
>> > But how about teaching squashfs to understand mtdX and mtd:name syntax
>> > instead?
>> Hi Artem,
>> I would not do that, squashfs and co just ask for a block device, putting mtdx
>> syntax awareness in each of them just does not seem a good fit to me.
> Right. But the same arguments applies to do_mounts.c which you hack:
To a far lesser extent, moreover do_mounts has similar hacks in that
regard, plus doing
this into squashfs you would have to do it everywhere else (e.g cramfs).
I just cannot agree, sorry.
> mtdblock is just a block device, putting awareness of specific types of
> block devices is not a good thing to do.
That was my point when you suggested hacking into squashfs to add mtd
> May be this is why I'm not too happy about your patch?
Neither am I, hence the way I tackled the matter.
This tweak, as I introduced it, is here to get better feedback.
>> BTW 'for-2.6.37' got https://patchwork.kernel.org/patch/145681/.
> Yeah, it is better to have a generic approach which can be applied to
> all block devices. Make UUID of your mtdblock to be equivalent to the
> name of the underlying mtd device and you are done: use
> PARTUUID=<mtd_device_name>. Right?
I put that link to bring back the discussion around something I would
more stick to
as I anticipated the taste of the reply.
Maybe we'll come easierly to a way of handling this matter with 'next-'s.
Though the mtd subsystem is probably one that would benefit from such
a name scheme,
the solution is on its way to come from another subsystem.
More information about the linux-mtd