[PATCH v2 0/6] Device table matching for SPI subsystem
Anton Vorontsov
avorontsov at ru.mvista.com
Thu Jul 30 20:39:57 EDT 2009
Andrew,
This new patch set overwrites following patches:
hwmon-lm70-convert-to-device-table-matching.patch
hwmon-adxx-convert-to-device-table-matching.patch
spi-merge-probe-and-probe_id-callbacks.patch
spi-prefix-modalias-with-spi.patch
of-remove-stmm25p40-alias.patch
mtd-m25p80-convert-to-device-table-matching.patch
spi-add-support-for-device-table-matching.patch
Changes since v1:
- Implemented Ben Dooks' idea of spi_get_device_id(), so we won't
call spi_match_id() twice for drivers that don't need the id.
- "spi: Merge probe and probe_id callbacks" patch no longer needed
as we don't change probe()'s arguments;
- Rename spi_device_id->data to driver_data, and turn it into
kernel_ulong_t to match majority of subsystems. Most drivers
don't need a pointer type anyway (e.g. m25p80 needs it, but
lm70 and adcxx don't);
- SPI_NAME_SIZE now defined to 32 (as it should be, using 20
for name size was a cut-n-paste typo from I2C defines).
Thanks!
--
Anton Vorontsov
email: cbouatmailru at gmail.com
irc://irc.freenode.net/bd2
More information about the linux-mtd
mailing list