nandwrite & jffs2 summary question

Gertjan Hofman gertjan_hofman at
Wed Jul 22 12:24:43 EDT 2009

Dear MTD experts,

I need a little advice on a problem I am seeing after switching on the CONFIG_JFFS2_SUMMARY option in a ARM 2.6.29-5 kernel.
I write the kernel uImage file to nand flash using nandwrite -p, after a flash_eraseall /dev/mtd1.  Then I reboot and U-boot uncompresses my kernel and starts it.

Since switching on the kernel flag, I get occasional CRC failure from U-boot. I have also had a message from nandwrite saying something like 'no room to write summary file'. (MTD partition is 3MB, kernel about 1.6MB) Re-writing usually solves the problem. I tried this on 2 boards, its not 100% repeatable but does happen.

I dont think I understand the interaction between the summary option on JFFS2 and nandwrite. I run sumtool on my jffs2 root filesystem image and burning that to /dev/mtd2 gives me no problem. 

Should I be doing anything to my kernel uImage before nandwriting ? Why does nandwrite even know about the summary file option ? Does it need a change to mkimage (from uboot) ?

Much appreciated,



More information about the linux-mtd mailing list