"Perhaps the file system was created with the wrong erasesize"

Nikhil nikhils at cdac.in
Tue Sep 13 02:42:24 EDT 2005

Hi all,

I am a newbie in this MTD field so perhaps my question might sound a bit

actually i was emulate the compact flash as mtd device, when i try to
mount jffs2 as an ordinary filesystem it is not working. it did work for a
Harddisk partition but when i used the same set of command to make the
same image on a compact flash through USB /dev/sdb2 things are not
working, mount is not sucessfull and i get the following msg :

empty flash at 0X004C8BFC ends at 0X004C8C00
CLEANMAKER node found at 0X004c8C00 not first node in block
node at 0X004CFFE4 with length 0X0000063C would run over the end of the
erase block

Perhaps the filesystem was created with the wrong erasesize?

Eep. Child "msg.h".......................

i am using linux kernel 2.6.12 with mtd support and relevant modules
compiled in kernel and BLKMTD as a loadable Kernel module

while insmod i am also specifying erase size as 64....
i had tried diff permutations of erasesize with insmod and the eraseblock
of mkfs.jffs2 command but the system hangs for CF and works fine in case
of harddisk 
i think many of you all must have gone through this one, i tried to get
around but i am in vain.

someone help!!
Nikhil Shirodkar
Project Engineer

More information about the linux-mtd mailing list