EBH question 1

Jarkko Lavinen jarkko.lavinen at nokia.com
Tue Dec 13 06:47:52 EST 2005


I tried CVS head (Dec 12).  I used on x86 and Nandsim.  2.6.14
requires removal of the second NULL argument (parent) to class_device_create() 
call to make it work.

I erased the partition with flash_eraseall (I tried both -j and without).
I mounted the partition, copied big file (libc) onto it, unmounted, and then
mounted again.

All messaged are directed to console, When I mount the file system
again, I get:

  # mount -t jffs2 /dev/mtdblock0 /mnt
  Dec 13 12:53:15 slayer kernel: Node at 0x00001e30 with length 0x000008e0 would run over the end of the erase block 
  Dec 13 12:53:15 slayer kernel: Perhaps the file system was created with the wrong erase size? Reject to mount.
  Dec 13 12:53:15 slayer kernel: [JFFS2 DBG] (3602) jffs2_do_mount_fs: build_fs failed
  mount: /dev/mtdblock0: can't read superblock

I can reproduce the same problem on an Arm based test board with 
2.6.15-rc4 with Nandsim and Onenandsim. On 2.6.15 class_device_create()
call works out of the box and no editing is needed.

Jarkko Lavinn

More information about the linux-mtd mailing list