what version of mkfs.jffs2 is recommended for 2.4.21

Vernon Fuller vernonfuller at gmail.com
Mon Dec 6 18:08:46 EST 2004

I am running 2.4.21-rmk2-pxa1 and am looking for matching mtd utilities.
I have tried mkfs.jffs2  1.41, 1.39 and even 1.26
what would you recommend?

The way I tell I have a mismatched version is jffs2_scan_eraseblock()
gets off and can't find more than a few Magic bitmasks on blocks that
should be formatted correctly.   My root jffs2 filesystem mounts,
after much of it has been erased.

More information about the linux-mtd mailing list