trouble with samsung drive

Matthew Dharm mdharm at
Mon Sep 1 15:18:36 EDT 2003

USB Mass Storage devices aren't handled via the MTD driver, generally.
They are handled by the usb-storage driver via SCSI emulation.

If the device shows up in /proc/bus/usb/devices with class code 8, then the
USB low-level is working and it's time to move on to enabling the
usb-storage driver.

The place for usb-storage help is linux-usb-users at


On Mon, Sep 01, 2003 at 11:54:48AM +0400, dima wrote:
> Hello!
> I got the Samsung flash drive last weekend. It looks like a noname one 
> marked as "Samsung 128MB, Made in Korea" only. It might be something of 
> the K9F28XXX0C series 
> (
> I tried to get it working on my old laptop on Sunday but failed. It 
> could be a problem with the USB hub since it is USB 1.1 & the flash 
> drive is reported to be USB 2.0. I searched the web & figured out that 
> Samsung chips must be NAND-compatible. I used DiskOnChip 2000 driver 
> first, but it failed to probe the device (btw, USB hub didn't report any 
> unclaimed devices). Then I tried almost all MTD drivers availble in the 
> standard ( kernel distribution (v2.4.20) -- none of them 
> seemed to probe the device successfully.
> So I have 3 questions:
> 1) Is this a problem with my old USB hub?
> 2) Which driver should I use if no?
> 3) I didn't enable SCSI emulation support in the kernel yet (I decided 
> to leave it for the next step since the device hadn't been detected). 
> Can it be the problem?
> ______________________________________________________
> Linux MTD discussion mailing list

Matthew Dharm                              Work: mdharm at
Senior Software Designer, Momentum Computer

More information about the linux-mtd mailing list