Problems with NFTL in 2.4.22

Karim Yaghmour karim at
Tue Nov 11 19:30:40 EST 2003

I haven't seen anything in the archives about this, so here goes:

I've had quite a few problems trying to interface with an 8MB DOC with
2.4.22. The system would simply freeze when I tried doing things like
mount, unmount, mke2fs, cat fs image to device, etc. No oops no nothing,
just the tools would not return to the command line and I'd have to
hard-reset the system. I tried a few variations in the commands to try
to get the same results, but nothing really got it working. I eventually
gave up and tried 2.4.21 instead, and then everything I was trying to
do before just worked fine ...

I cannot say exactly what's the problem, and I don't have the time
to track it down, but I can say that 2.4.22 has a problem with handling
at least the 8MB DOC.


Author, Speaker, Developer, Consultant
Pushing Embedded and Real-Time Linux Systems Beyond the Limits || karim at || 514-812-4145

More information about the linux-mtd mailing list