unable to detect NFTL partition with kernel 2.5.59

Thomas Wehrspann thomas at wehrspann.de
Fri Jan 17 12:20:04 EST 2003

Hallo list

I am trying to use a DoC Millenium with LinuxBIOS and a developer kernel
2.5.5x but ended in a kernel panic because of a missing root device.
Then i tried it without LinuxBIOS an MTD as modules.
I did a (modules-init-tools-0.9.7)
    insmod docecc.ko
    insmod mtdcore.ko
    insmod doc2001.ko
    insmod doprobe.ko
and the chips seems to be recognized correctly, then
    insmod nftl

NFLT driver: nftlcore.c $Revision: 1.82 $, nftlmount.c $Revision: 1.25 $
Cannot calculate an NFTL geometry to match size of 0x2fb0.
Using C:1017 H:12 S:1 (== 0x2fac sects)

and nothing else wether i uses DEBUG or not. With kernel 2.4.19 there is
also a
nftla: p1
and it works perfectly (I want to use the 2.5.5x cause of the build in DVB
I tried the CVS driver, but had no luck compiling it (seems a bit outdated
for a 2.5.5x IMHO).

Thomas Wehrspann

More information about the linux-mtd mailing list