2.5 questions

Kyle Harris kharris at nexus-tech.net
Fri Sep 13 07:50:07 EDT 2002

On Friday 13 September 2002 03:24 am, David Woodhouse wrote:

> kharris at nexus-tech.net said:
> > How do I get the latest code base for 2.5 kernels? I pulled the latest
> > cvs  but it appears this must be for 2.4 since it doesn't compile. Is
> > there a  separate branch for 2.5?
> Should do. What breaks? It'll only be cosmetic, surely?

I ran the pathcin.sh script to set this up. Below is first error, which is 
2.4 - 2.5 related (MINOR() and kdev_t stuff).

  arm-linux-gcc -Wp,-MD,./.mtdchar.o.d -D__KERNEL__ 
-I/home/kyle/handheld/homebase/kernel/linux-2.5.30.newmtd/include -Wall 
-Wstrict-prototypes -Wno-trigraphs -Os -fno-strict-aliasing -fno-common -g 
-mapcs -mapcs-32 -D__LINUX_ARM_ARCH__=5 -march=armv4 -Wa,-mxscale  
-mtune=strongarm  -mshort-load-bytes -msoft-float -Wa,-mno-fpu -nostdinc 
-iwithprefix include    -DKBUILD_BASENAME=mtdchar   -c -o mtdchar.o mtdchar.c
mtdchar.c: In function `mtd_open':
mtdchar.c:63: invalid operands to binary &
make[2]: *** [mtdchar.o] Error 1
make[2]: Leaving directory 
make[1]: *** [mtd] Error 2
make[1]: Leaving directory 
make: *** [drivers] Error 2

> > How stable is mtd for 2.5? I'm seeing some very strange behavior where
> > if I  make slight mods to even script files, the files become unusable
> > and cause  the system to hang. I'm running 2.5.30-rmk1-pxa1 with jffs2
> > root fs.
> Not expected to break. Not highly tested either. More details please.
> SysRq-T is your friend.

I'm still not entirely sure what's happening. It may be a race condition at 
boot that is breaking something and completely unrelated to the minor changes 
I made to the root fs. I'm not familiar sith SysRq-T. Where do I find more 
about this?

Thanks. Kyle.

More information about the linux-mtd mailing list