seeking help on JFFS2

Junping Zhang JZhang at
Tue Nov 5 12:39:31 EST 2002

Yes, the minor number is 2, and I checked mkfs.jffs2 source, hex is ok. I
also tried with
the method you mentioned, the crashed happened right away.

I just tried using the stock JFFS2 in 2.4.18 kernel. It actually got me
further than JFFS2
in my mtd-20021022 snapshot, I could use either image or direct mount to
create JFFS2,
but it still crashed under stress test. On the other hand, JFFS works quite

Does stock 2.4.19 have a stable JFFS2 without patch? I downloaded a
shared-zlib patch
for 2.4.19-pre10 but am not sure it will fix my JFFS2 problem.

Thanks a lot

- Junping

> -----Original Message-----
> From:	Jörn Engel [SMTP:joern at]
> Sent:	Tuesday, November 05, 2002 11:41 AM
> To:	Junping Zhang
> Cc:	linux-mtd at
> Subject:	Re: seeking help on JFFS2
> >         eraseall /dev/mtd1
> >         mount -t jffs /dev/mtdblock1 /mnt/flash
> Just to be on the safe side, can you make sure that /dev/mtd1 has minor
> number 2? Common problem.
> > 
> >         mkfs.jffs2 -dipc -e0x40000 -p0x700000 -b -o /opt/ipc.jffs2
>                              ^^^^^^^   ^^^^^^^^
> Does this really work? I remember that mkfs.jffs2 once didn't
> understand hex and you had to pass it the decimal numbers. Can you
> check that?
> > 
> >   Any ideas? I have been reading the mailing list archive and could
> > not find the answer to this.
> jffs2 also mounts partitions that are completely erased. You can
> eraseall /dev/mtd1 and then mount /dev/mtdblock1. That should work
> fine.
> Jörn
> -- 
> "Translations are and will always be problematic. They inflict violence 
> upon two languages." (translation from German)

More information about the linux-mtd mailing list