Trouble indetifying FLASH part

Ho-Kuo Chan hchan at
Thu May 16 10:12:15 EDT 2002

> >  I have also tried replacing the ioremap call in init)physmap with
> > ioremap_nocache() but with no byte swapping. Should I try it with
> Yes, that could be useful -- although I don't think you should have got a
> cached mapping by default, it's worth a try.
The ioremap_nocache with LE_BYTE_SWAP didn't help. I will return it ioremap.

> Can you make it print the contents of the region at 0x8000000 and check it
> matches what you expect to be in the flash chip?
I tried printk("HKC: Raw output of flash address =0x%x\n", *(unsigned
int*)0x8000000) but resulted in kernel panic. I'm starting to think this is
a virtual memory problem. Do I need a TLB entry for the device?

> Are you sure that's
> supposed to be 0x8000000 and not 0x80000000?
Yes, I have double-checked the hardware specs. I also have the board and
flash working with VxWorks which has a flat memory model.

Any other ideas?



More information about the linux-mtd mailing list