Problem: 51MB partition max size on jffs2

Ken Offer koffer at
Wed Dec 4 18:08:07 EST 2002

On Wednesday, December 4, 2002, at 04:02  PM, Thomas Gleixner wrote:

> On Wednesday 04 December 2002 23:00, Ken Offer wrote:
>> On Wednesday, December 4, 2002, at 11:47  AM, Thomas Gleixner wrote:
>>> Latest CVS code ?
>> I tried it with an older version (circa 20020819) and the latest code
>> (20021202).  Same result.  I am going to try the change Dave Ellis
>> <DGE at> suggested.
> Strange. Could you please tell me, what output the latest CVS code 
> produces

Well, I was getting a mount failure.  There wasn't much info other than 
that.  If you look in the latest (20021202) jffs2 build.c file, you can 
see if the kmalloc of c->blocks fails in jffs2_do_mount_fs, no debug 
message is printed.  Only a non-mem error is returned.  That is 
consistent with what I was seeing, even with the highest verbosity 
debugging on.

I made the change to use vmalloc/vfree for c->blocks and that seemd to 
fix the problem.  kmalloc is indeed limited to 128KB.  Of course, I 
made the change to the 20020819 code.  I'll try the vmalloc change with 
the latest CVS code as well and see how that holds up.

|  Ken Offer        koffer at         ARL:UT  |
|  Office: 512-835-3859                  Fax: 512-835-3259  |

More information about the linux-mtd mailing list