GRUB patch won't stick ;-(

John Sutton john at
Sat Apr 27 15:24:57 EDT 2002

Hi there

Sorry if I'm being dumb, but I can't manage to patch the grub source...

Here is what I've done.

Downloaded the latest mtd from cvs and in the directory patches found:


I tried to patch grub v 0.91 (i.e the latest release) with this but it fails. 
So I figured what I needed to do was get the source version of grub
corresponding to when the patch was made.  So, I used this command to retrieve
a version of grub from cvs:

cvs -z3 -d:pserver:anoncvs at co -D 2002-02-19 grub

which seemed to work fine, and then tried to patch this version.  But it still
fails thus (and this looks very similar to the failure against the 0.91 source):

patching file AUTHORS
patching file ChangeLog
patching file README_DiskOnChip
patching file
patching file
Hunk #1 FAILED at 1.
Hunk #2 FAILED at 89.
2 out of 2 hunks FAILED -- saving rejects to file
patching file doc_stage1.S
patching file doc_stage1.h
patching file doc_stage1b.S
patching file makecsum.c
patching file
Hunk #1 FAILED at 85.
1 out of 1 hunk FAILED -- saving rejects to file
can't find file to patch at input line 1246
Perhaps you should have used the -p or --strip option?
The text leading up to this was:
|Index: stage2/asm.S
|RCS file: /usr/local/cvsroot/grub/stage2/asm.S,v
|retrieving revision
|retrieving revision 1.3
|diff -u -r1.1.1.2 -r1.3
|--- stage2/asm.S       10 Feb 2002 16:05:37 -0000
|+++ stage2/asm.S       10 Feb 2002 17:03:08 -0000      1.3
File to patch:            (I gave up here...)

What am I doing wrong...?


John Sutton
SCL Internet
Tel. +44 (0) 1239 711 888

More information about the linux-mtd mailing list