lilo and mtd ans doc

Patrick Allaire pallaire at
Tue Sep 4 09:43:57 EDT 2001

I have tried what you have told me but it does not seem to change a thing
!!! The systems is still hanging on "Kernel panic : VFS: Unable to mount
root fs on 03:05" !!!!!!!!!

Where does it find the information to search 03:05 to boot ? I did compile
the kernel on /dev/hda5 !!! Is there a place in the kernel config where I
could specify the boot device ? Is this information stored in boot.b-mtd (I
dont think so) ? In the /boot/map ??? the last one is generated by lilo ? no
? so it should not contain /dev/hda5 information since I run lilo-mtd from a
floppy the HD was removed !

I have added those two lines to my lilo.conf :


Then I have tried what you told me. When I boot ... I write :

lilo: s append="root=/dev/nftla1"

For your question about why I am using /dev/nftla1 instead of /dev/nftla ...
its because on our final product we will have multiple partitions.

Thank you !

Patrick Allaire
mailto:pallaire at
If you can see it, but it's not there, it's virtual. 
If you can't see it, but it is there, it's hidden. 
It you can't see it and it isn't there, it's gone.

> -----Original Message-----
> From: David Woodhouse [mailto:dwmw2 at]
> Sent: August 31, 2001 5:37 PM
> To: Patrick Allaire
> Cc: linux-mtd at
> Subject: Re: lilo and mtd ans doc 
> pallaire at said:
> > Kernel Panic : VFS: unable to mount root fs on 03:05 
> Er, that's /dev/hda5. It's not trying to mount the DiskOnChip at all.
> Try append="root=/dev/nftla1" instead of just root=/dev/nftla1
> LILO sucks like that.
> BTW, how many partitions do you have on the DiskOnChip? If 
> only one, why 
> are you wasting space on partitions rather than just using a 
> filesystem on 
> /dev/nftla ?
> --
> dwmw2

More information about the linux-mtd mailing list