MTD newbie

Cristiano Paris at
Mon Oct 1 11:52:28 EDT 2001

Many thanks to all.

At the moment the jffs2 is unusable for me. I'm using linux-2.4.9-ac10 on
a Pentium166MMX notebook. I've tried to mount the task-familiar
distribution on /dev/mtdblock0. The mount works fine but when I try to
touch a file in the filesystem (say "touch /mnt/silly") the system just
hangs and a kernel oops appears.

touch seems to stop after perfoming a utime system call (open and close
worked fine) and the kernel provides the following backtrace :

- system_call
- sys_close
- filp_close
- sys_utime
- notify_change (setattr)
- jffs2_setattr
- jffs2_complete_reservation
- jffs2_garbage_collect_trigger

The error is "Invald parameter 00000"; I'm trying to get the full OOPS
from a serial-line-attached console, so be patient. In addition I'm trying
to debug the error myself.

Maybe I'm using the wrong version of Linux or a more recent snapshot would
sove the problem.

Please, let me know. Thanks in advance, as usual.


More information about the linux-mtd mailing list