problems to write a partition table

Fend, Matthias mfend at
Fri Nov 16 10:11:42 EST 2001

i guess you get this message 
"nftla : unknown partition table"
if you try to write the partition(s) with fdisk ?

if yes check if you've enabled the partition type support (for example MSDOS
partition tables) in your kernel configuration.

the same for the filesystem stuff ... after solving the partition problem :-)


	-----Ursprüngliche Nachricht-----
	Von:	Fend, Matthias 
	Gesendet am:	Freitag, 16. November 2001 16:04
	An:	Fend, Matthias

	Useing a doc2000 device (32Mb) and a kernel v2.4.14.

	After insert some MTD modules :
	mtdcore docecc doc2000 mtdchar mtdblock and nftl;
	I run nflt_format to format my doc2000 chip;
	but it complain :Erasesize not 8Kb - I'm confused!

	For someone's advice I skip the erasesize check in nftl_format.c.
	so nftl_format works well.
	but when I run fdisk on /dev/nftla.
	it's say :
	You will not be able to write partition table.
	Device contains neither a valid DOS partition table, nor Sun, SGI or OSF
	disklabel Building a new DOS disklabel.Changes will remain in memory
	you decide to write them.After that, of course,the previous content
won't be

	Command (m for help):

	Even if I created a partition and enter "w",the partition also can not
be writed
	into /dev/nftla.

	run nftldump on /dev/mtd0:
	NFTL Media Header found at offset 0x00000000:
	NumEraseUnits: 2048
	Formatted Size:33488896
	UnitSizeFactor: 0xff
	Second NFTL Media Header found at offset 0x00004000
	Unit 0 is free
	Unit 1 is free

More information about the linux-mtd mailing list