StrataFlash and patching 2.2.16

Daniel Manesajian dmanesajian at
Thu Nov 8 13:34:03 EST 2001

Hi list,

This is my first post here. I've been looking at MTD for a few days now as a
solution for getting the Intel Advanced StrataFlash working under Linux.

I've downloaded the latest code from CVS and read the document
"mtd-jffs-HOWTO.txt". I've also started looking through the source code. I
hoping someone can help me with a few questions. First of all, will MTD
support the StrataFlash "out of the box" or will I have to write an MTD
driver for it? Second, I'm running kernel version 2.2.16 and don't see a
corresponding patch at On the MTD
web page it did mention a patch for 2.2.16 but is this kernel no longer
supported? If not is my only option to upgrade my kernel (this isn't very
feasible due to an external vendor's kernel modifications)?

Thank you for your help.

Daniel Manesajian

More information about the linux-mtd mailing list