m-systems doc 2000 : no free space left

oskaya at softhome.net oskaya at softhome.net
Sun Feb 11 06:00:27 EST 2001

   here i'm at work in order to grab the latest version from cvs and give
msystems flashdisk a try ...
   I have downloaded the latest version using cvs  commands found in mtd
home page . At first i tried to compile it by typing make at the source
directory . It gave some errors related to something is not defined . Then
i decided to compile it by putting it in the kernel with applying
patchin.sh and building it as module . I was able to compile the modules .
I run insmod command in the order provided in a previous mail . It finds
Diskonchip at 0xd6000 address . The same things occurred . It has gone to a
deadlock while making filesystem . The message is below :

writing superblocks and filesystem accounting information : Argh ! No free
blocks found ! LastFreeEUN=3068 FirstEUN = 32768 .

M-Systems DiskOnChip driver...
Using configured probe address 0xd6000
DiskOnChip 2000 found at address 0xd6000
Cannot calculate an NFTL geometry to match size of 0xbba0.
Using C:1000: H:16 S:3 ( == 0xbb80 sects)

To unsubscribe, send "unsubscribe mtd" to majordomo at infradead.org

More information about the linux-mtd mailing list