ASA atris at
Thu Aug 23 08:42:42 EDT 2001

Hello all,

tried anybody to use *fdisk on DiskOnChip2000 from ramdisk
and got expected results?

I'm automating linux installation, so such thing is needed...

My system consists of:
  special embedded motherboard with AMD 486DX4-100
  8 MB RAM
  DiskOnChip 2000 (8 MB flash)
  linux kernel 2.4.1 with MTD 20010730 snapshot
  root filesystem on /dev/ram0 (loaded via cmdline: initrd=inird.gz root=/dev/ram0)

All is based on debian potato (2.2; glibc 2.1; some utils, including
  sfdisk, are upgraded in order to proper work with 2.4 kernel)

Symptoms are:
after executing

  #deleting any partition for sanity
  dd if=/dev/zero of=/dev/nftla bs=512 count=1
  # BLKRRPART ioctl (reread partition information)
  sfdisk -R /dev/nftla

  # making 5 and 3 megs partitions on 8 MiB DOC
  echo ",5000,L,*;,,L;;" | sfdisk -f /dev/nftla

  # make sure partition information is reread
  sfdisk -R /dev/nftla

the root filesystem (ramdisk) is screwed up!

again, after clean reboot only invoking
BLKRRPART ioctl is enough to break ramdisk

in the same configuration, operating with hard disks instead of DOC
is absolutely .

Also, to reproduce this bug in other environment (only the kernel is
the same) I tried to put my kernel (2.4.1+MTD-20010730) on the debian
installation diskette and after using cfdisk ramdisk was screwed again...

Best regards,
 ASA                            mailto:atris at

More information about the linux-mtd mailing list