MTD with 2.2.14 kernel

Dvir Oren dviro at
Thu Mar 23 15:23:53 EST 2000

> I don't need to use nftl_format in order to be able to write to the
> flash using the MTD drivers. I have managed to write successfully to a
> DOC having formated it using the M-Systems utilities, dformat and

I tried your patches for the kernel and they worked!  Thank you.  I 
don't understand, though, why didn't my patches work.  They are 
very similar.  Perhaps I initialized MTD too late, or something like 
that.  Maybe I'll look into it.

However, whenever I try to write to the flash without nftl_formating it 
first, I get errors.  And I still wasn't able to boot from the flash.  
LILO starts loading, but gets stuck either at LI or LIL-.  Oh well.  I 
don't understand why it works for you, but doesn't for me.  I also 
keep getting file system corruption.

Thanks for the help.

Dvir Oren <dviro at>
Lucid VON Ltd.     <>
9 Saloniki St.,        Tel-Aviv       Israel
Tel:  +972 3 644 3038  Fax:  +972 3 644 3039

To unsubscribe, send "unsubscribe mtd" to majordomo at

More information about the linux-mtd mailing list