mtd: dataflash: Improve coding style in jedec_probe()

Linux-MTD Mailing List linux-mtd at lists.infradead.org
Thu Jul 13 10:59:02 PDT 2017


Gitweb:     http://git.infradead.org/?p=mtd-2.6.git;a=commit;h=41c9c6621afa22c86fe74cf07536fd21c7719ca6
Commit:     41c9c6621afa22c86fe74cf07536fd21c7719ca6
Parent:     c41e43c6faf68a9b70afdb0dfee45d196c27031b
Author:     Andrey Smirnov <andrew.smirnov at gmail.com>
AuthorDate: Fri Apr 21 09:30:22 2017 -0700
Committer:  Brian Norris <computersforpeace at gmail.com>
CommitDate: Thu May 11 10:04:19 2017 -0700

    mtd: dataflash: Improve coding style in jedec_probe()
    
    Change the following:
    
       - Replace indentation between type and name of local variable from
         tabs to spaces
    
       - Replace magic number 0x1F with CFI_MFR_ATMEL macro
    
       - Replace variable 'tmp' with 'ret' and 'i' where appropriate
    
       - Reformat multi-line comments and add newlines where appropriate
    
    No functional change intended.
    
    Cc: cphealy at gmail.com
    Cc: David Woodhouse <dwmw2 at infradead.org>
    Cc: Brian Norris <computersforpeace at gmail.com>
    Cc: Boris Brezillon <boris.brezillon at free-electrons.com>
    Cc: Richard Weinberger <richard at nod.at>
    Cc: Cyrille Pitchen <cyrille.pitchen at atmel.com>
    Cc: Marek Vasut <marek.vasut at gmail.com>
    Cc: linux-kernel at vger.kernel.org
    Acked-by: Marek Vasut <marek.vasut at gmail.com>
    Tested-by: Chris Healy <cphealy at gmail.com>
    Signed-off-by: Andrey Smirnov <andrew.smirnov at gmail.com>
    Signed-off-by: Brian Norris <computersforpeace at gmail.com>
---
 drivers/mtd/devices/mtd_dataflash.c | 31 +++++++++++++++++--------------
 1 file changed, 17 insertions(+), 14 deletions(-)

diff --git a/drivers/mtd/devices/mtd_dataflash.c b/drivers/mtd/devices/mtd_dataflash.c
index a566231..5b7a8c3 100644
--- a/drivers/mtd/devices/mtd_dataflash.c
+++ b/drivers/mtd/devices/mtd_dataflash.c
@@ -82,6 +82,7 @@
 #define OP_WRITE_SECURITY_REVC	0x9A
 #define OP_WRITE_SECURITY	0x9B	/* revision D */
 
+#define CFI_MFR_ATMEL		0x1F
 
 struct dataflash {
 	u8			command[4];
@@ -738,14 +739,15 @@ static struct flash_info dataflash_data[] = {
 
 static struct flash_info *jedec_probe(struct spi_device *spi)
 {
-	int			tmp;
-	u8			code = OP_READ_ID;
-	u8			id[3];
-	u32			jedec;
-	struct flash_info	*info;
+	int ret, i;
+	u8 code = OP_READ_ID;
+	u8 id[3];
+	u32 jedec;
+	struct flash_info *info;
 	int status;
 
-	/* JEDEC also defines an optional "extended device information"
+	/*
+	 * JEDEC also defines an optional "extended device information"
 	 * string for after vendor-specific data, after the three bytes
 	 * we use here.  Supporting some chips might require using it.
 	 *
@@ -753,13 +755,14 @@ static struct flash_info *jedec_probe(struct spi_device *spi)
 	 * That's not an error; only rev C and newer chips handle it, and
 	 * only Atmel sells these chips.
 	 */
-	tmp = spi_write_then_read(spi, &code, 1, id, 3);
-	if (tmp < 0) {
+	ret = spi_write_then_read(spi, &code, 1, id, 3);
+	if (ret < 0) {
 		pr_debug("%s: error %d reading JEDEC ID\n",
-			dev_name(&spi->dev), tmp);
-		return ERR_PTR(tmp);
+			dev_name(&spi->dev), ret);
+		return ERR_PTR(ret);
 	}
-	if (id[0] != 0x1f)
+
+	if (id[0] != CFI_MFR_ATMEL)
 		return NULL;
 
 	jedec = id[0];
@@ -768,9 +771,9 @@ static struct flash_info *jedec_probe(struct spi_device *spi)
 	jedec = jedec << 8;
 	jedec |= id[2];
 
-	for (tmp = 0, info = dataflash_data;
-			tmp < ARRAY_SIZE(dataflash_data);
-			tmp++, info++) {
+	for (i = 0, info = dataflash_data;
+			i < ARRAY_SIZE(dataflash_data);
+			i++, info++) {
 		if (info->jedec_id == jedec) {
 			pr_debug("%s: OTP, sector protect%s\n",
 				dev_name(&spi->dev),



More information about the linux-mtd-cvs mailing list