bitops: rename for_each_bit() to for_each_set_bit(): mtd
Linux-MTD Mailing List
linux-mtd at lists.infradead.org
Thu Apr 8 04:59:01 EDT 2010
Gitweb: http://git.infradead.org/?p=mtd-2.6.git;a=commit;h=fed457a83611182f5a2e049cce02f8f4e1b65644
Commit: fed457a83611182f5a2e049cce02f8f4e1b65644
Parent: 8da552f26107f55186346cff280ec9d53cc42add
Author: Akinobu Mita <akinobu.mita at gmail.com>
AuthorDate: Mon Apr 5 13:53:35 2010 -0700
Committer: David Woodhouse <David.Woodhouse at intel.com>
CommitDate: Thu Apr 8 09:42:41 2010 +0100
bitops: rename for_each_bit() to for_each_set_bit(): mtd
Rename for_each_bit() to for_each_set_bit in the kernel source tree. To
permit for_each_clear_bit(), should that ever be added.
I'll be sending a patch to Linus this week which removes the temporary
for_each_bit() macro, so this patch will be needed to avoid build
breakage.
Suggested-by: Alexey Dobriyan <adobriyan at gmail.com>
Suggested-by: Andrew Morton <akpm at linux-foundation.org>
Signed-off-by: Akinobu Mita <akinobu.mita at gmail.com>
Cc: "David S. Miller" <davem at davemloft.net>
Cc: Russell King <rmk at arm.linux.org.uk>
Cc: David Woodhouse <dwmw2 at infradead.org>
Cc: Artem Bityutskiy <dedekind at infradead.org>
Cc: Stephen Rothwell <sfr at canb.auug.org.au>
Signed-off-by: Andrew Morton <akpm at linux-foundation.org>
Signed-off-by: David Woodhouse <David.Woodhouse at intel.com>
---
drivers/mtd/sm_ftl.c | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/drivers/mtd/sm_ftl.c b/drivers/mtd/sm_ftl.c
index 4c21589..67822cf 100644
--- a/drivers/mtd/sm_ftl.c
+++ b/drivers/mtd/sm_ftl.c
@@ -934,7 +934,7 @@ int sm_cache_flush(struct sm_ftl *ftl)
/* Try to read all unread areas of the cache block*/
- for_each_bit(sector_num, &ftl->cache_data_invalid_bitmap,
+ for_each_set_bit(sector_num, &ftl->cache_data_invalid_bitmap,
ftl->block_size / SM_SECTOR_SIZE) {
if (!sm_read_sector(ftl,
More information about the linux-mtd-cvs
mailing list