[PATCH v6 04/16] usb: hub: Use assign_bit() in usb_hub_set_port_power()

Bartosz Golaszewski brgl at kernel.org
Tue Jul 21 02:09:46 PDT 2026


On Tue, 21 Jul 2026 08:53:59 +0200, Chen-Yu Tsai <wenst at chromium.org> said:
> usb_hub_set_port_power() open-codes assign_bit(). Just use the
> assign_bit() macro instead. This makes subsequent additions to
> usb_hub_set_port_power() easier to read.
>
> This change does not introduce any functional changes.
>
> Suggested-by: Andy Shevchenko <andriy.shevchenko at linux.intel.com>
> Reviewed-by: Andy Shevchenko <andriy.shevchenko at linux.intel.com>
> Signed-off-by: Chen-Yu Tsai <wenst at chromium.org>
> ---

Reviewed-by: Bartosz Golaszewski <bartosz.golaszewski at oss.qualcomm.com>



More information about the Linux-mediatek mailing list