[PATCH net-next v9 1/3] net: airoha: rename airoha_priv_flags to airoha_dev_flags
Jacob Keller
jacob.e.keller at intel.com
Mon Jul 20 15:36:53 PDT 2026
On 7/20/2026 3:03 PM, Lorenzo Bianconi wrote:
> Rename the airoha_priv_flags enum to airoha_dev_flags and the
> AIROHA_PRIV_F_WAN flag to AIROHA_DEV_F_WAN. The "priv_flags" naming
> dates back to an earlier design that used ethtool private flags; since
> this series switched to tc qdisc offload for LAN/WAN configuration,
> align the naming to reflect that these are per-device flags rather than
> ethtool private flags. No functional change.
>
> Reviewed-by: Simon Horman <horms at kernel.org>
> Reviewed-by: Alexander Lobakin <aleksander.lobakin at intel.com>
> Signed-off-by: Lorenzo Bianconi <lorenzo at kernel.org>
> ---
Reviewed-by: Jacob Keller <jacob.e.keller at intel.com>
More information about the Linux-mediatek
mailing list