[PATCH v5 04/16] usb: hub: Use assign_bit() in usb_hub_set_port_power()

Andy Shevchenko andriy.shevchenko at linux.intel.com
Wed Jul 15 02:11:02 PDT 2026


On Wed, Jul 15, 2026 at 04:53:34PM +0800, Chen-Yu Tsai wrote:
> usb_hub_set_port_power() open-codes assign_bit(). Just use the
> assign_bit() macro instead. This makes subsequent additions to
> usb_hub_set_port_power() easier to read.
> 
> This change does not introduce any functional changes.

Yes, it's a pure cleanup.

Reviewed-by: Andy Shevchenko <andriy.shevchenko at linux.intel.com>

-- 
With Best Regards,
Andy Shevchenko





More information about the Linux-mediatek mailing list