[PATCH v2 05/46] drm/mediatek: Add missing component types in mtk_ddp_comp_type
AngeloGioacchino Del Regno
angelogioacchino.delregno at collabora.com
Tue Jul 14 04:43:33 PDT 2026
In preparation to remove the mtk_ddp_comp_id enumeration, add the
missing component types ETHDR_MIXER, PADDING and MDP_RDMA in the
mtk_ddp_comp_type enumeration.
Signed-off-by: AngeloGioacchino Del Regno <angelogioacchino.delregno at collabora.com>
---
include/linux/soc/mediatek/mtk-mmsys.h | 5 +++++
1 file changed, 5 insertions(+)
diff --git a/include/linux/soc/mediatek/mtk-mmsys.h b/include/linux/soc/mediatek/mtk-mmsys.h
index fb88202d100a..3ddfdeac658d 100644
--- a/include/linux/soc/mediatek/mtk-mmsys.h
+++ b/include/linux/soc/mediatek/mtk-mmsys.h
@@ -92,6 +92,7 @@ enum mtk_ddp_comp_type {
MTK_DISP_COLOR,
MTK_DISP_DITHER,
MTK_DISP_DSC,
+ MTK_DISP_ETHDR_MIXER,
MTK_DISP_GAMMA,
MTK_DISP_MERGE,
MTK_DISP_MUTEX,
@@ -99,12 +100,16 @@ enum mtk_ddp_comp_type {
MTK_DISP_OVL,
MTK_DISP_OVL_2L,
MTK_DISP_OVL_ADAPTOR,
+ MTK_DISP_PADDING,
MTK_DISP_POSTMASK,
MTK_DISP_PWM,
MTK_DISP_RDMA,
MTK_DISP_UFOE,
MTK_DISP_WDMA,
+ /* MDP Components */
+ MTK_DISP_MDP_RDMA,
+
/* Keep Display outputs at the end for readability */
MTK_DPI,
MTK_DP_INTF,
--
2.54.0
More information about the Linux-mediatek
mailing list