[PATCH v1 5/5] drm/mediatek: mtk_dpi: Rename output fmts array for MT8195 DP_INTF
CK Hu (胡俊光)
ck.hu at mediatek.com
Mon Apr 21 23:04:03 PDT 2025
On Wed, 2025-04-09 at 15:13 +0200, AngeloGioacchino Del Regno wrote:
> External email : Please do not click links or open attachments until you have verified the sender or the content.
>
>
> For the sake of increasing human readability and avoid possible
> confusion between DPI and DP_INTF output formats (as the two are
> ever so slightly different), rename the mt8195_output_fmts array
> to mt8195_dp_intf_output_fmts.
>
> This commit brings no functional changes.
Reviewed-by: CK Hu <ck.hu at mediatek.com>
>
> Signed-off-by: AngeloGioacchino Del Regno <angelogioacchino.delregno at collabora.com>
> ---
> drivers/gpu/drm/mediatek/mtk_dpi.c | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/gpu/drm/mediatek/mtk_dpi.c b/drivers/gpu/drm/mediatek/mtk_dpi.c
> index 9de537a77493..0b7f91fb519f 100644
> --- a/drivers/gpu/drm/mediatek/mtk_dpi.c
> +++ b/drivers/gpu/drm/mediatek/mtk_dpi.c
> @@ -1106,7 +1106,7 @@ static const u32 mt8195_dpi_output_fmts[] = {
> MEDIA_BUS_FMT_YUV10_1X30,
> };
>
> -static const u32 mt8195_output_fmts[] = {
> +static const u32 mt8195_dp_intf_output_fmts[] = {
> MEDIA_BUS_FMT_RGB888_1X24,
> MEDIA_BUS_FMT_RGB888_2X12_LE,
> MEDIA_BUS_FMT_RGB888_2X12_BE,
> @@ -1248,8 +1248,8 @@ static const struct mtk_dpi_conf mt8195_dpintf_conf = {
> .dpi_factor = dpi_factor_mt8195_dp_intf,
> .num_dpi_factor = ARRAY_SIZE(dpi_factor_mt8195_dp_intf),
> .max_clock_khz = 600000,
> - .output_fmts = mt8195_output_fmts,
> - .num_output_fmts = ARRAY_SIZE(mt8195_output_fmts),
> + .output_fmts = mt8195_dp_intf_output_fmts,
> + .num_output_fmts = ARRAY_SIZE(mt8195_dp_intf_output_fmts),
> .pixels_per_iter = 4,
> .dimension_mask = DPINTF_HPW_MASK,
> .hvsize_mask = DPINTF_HSIZE_MASK,
> --
> 2.49.0
>
More information about the Linux-mediatek
mailing list