[PATCH v2 1/2] ufs: core: fix the issue of ICU failure

Peter Wang (王信友) peter.wang at mediatek.com
Sun Sep 8 20:38:22 PDT 2024


On Thu, 2024-09-05 at 14:06 -0700, Bart Van Assche wrote:
>  	 
> External email : Please do not click links or open attachments until
> you have verified the sender or the content.
>  On 9/1/24 7:18 PM, peter.wang at mediatek.com wrote:
> >   /* SQRTCy.ICU = 1 */
> 
> Feel free to leave out the above comment since it duplicates the code
> below this comment. A comment that explains that "ICU = Initiate
> Cleanup" probably would be appropriate.
> 

Hi Bart,

Will change comment to  "/* Initiate Cleanup */"


> > -writel(SQ_ICU, opr_sqd_base + REG_SQRTC);
> > +writel(readl(opr_sqd_base + REG_SQRTC) | SQ_ICU,
> > +opr_sqd_base + REG_SQRTC);
> 
> Is this perhaps an open-coded version of ufshcd_rmwl()?
> 
> 

ufshcd_rmwl usage includes mmio_base, and it's not suitable for use
here.

> >   
> >   /* Poll SQRTSy.CUS = 1. Return result from SQRTSy.RTC */
> >   reg = opr_sqd_base + REG_SQRTS;
> >   err = read_poll_timeout(readl, val, val & SQ_CUS, 20,
> >   MCQ_POLL_US, false, reg);
> > -if (err)
> > -dev_err(hba->dev, "%s: failed. hwq=%d, tag=%d err=%ld\n",
> > -__func__, id, task_tag,
> > +if (err || FIELD_GET(SQ_ICU_ERR_CODE_MASK, readl(reg)))
> > +dev_err(hba->dev, "%s: failed. hwq=%d, tag=%d err=%d RTC=%ld\n",
> > +__func__, id, task_tag, err,
> >   FIELD_GET(SQ_ICU_ERR_CODE_MASK, readl(reg)));
> 
> In the above code the expression "FIELD_GET(SQ_ICU_ERR_CODE_MASK, 
> readl(reg))" occurs twice. Please consider storing that expression in
> a variable such that this expression only occurs once.
> 

Will use a variable.

Thanks.
Peter


> Thanks,
> 
> Bart.
> 


More information about the Linux-mediatek mailing list